Unbekannter Fehler 130 beim Versuch, die Anwendung auf Controllino zu laden
Symptom:
Nach dem Versuch, die Anwendung auf einen →Controllino zu laden, wird der Text Unbekannter Fehler "130" bei der Ausführung eines Zielsystem-Kommandos als Ausführungsstatus in der Sicht Instanzen angezeigt. Die Anwendung wird nicht geladen.
Nachdem die Ursache (siehe unten) behoben wurde, ist im Projekt das Zielsystem zwar passend eingestellt, beim erneuten Laden der Anwendung wird aber weiterhin der unbekannte Fehler "130" angezeigt.
Ursache:
Beim Zielsystem handelt oder handelte es sich um eine andere Ausbaustufe, als für das Projekt eingestellt ist. Beispiel: Beim Zielsystem handelt es sich um einen Controllino MINI, während als Projektvorlage jene für einen Controllino MAXI gewählt wurde.
Lösung:
Erstellen Sie ein Projekt für die passende Controllino-Ausbaustufe. Beispiel: Bei Controllino MINI als Zielsystem verwenden Sie die Projektvorlage für Controllino MINI.
Erstellen Sie die benötigte Funktionalität im neuen Projekt. Je nach Umfang können Sie z.B. die benötigten ST-Objekte in das neue Projekt verschieben. Verschieben Sie jedoch nicht das SPS-Objekt, da das SPS-Objekt des neuen Projekts die passenden Einstellungen für die Ausbaustufe enthält. Möglicherweise müssen Sie die Zuordnung des Programtyps im SPS-Objekt des neuen Projekts anpassen.
Verbinden Sie sich nun in der Sicht Instanzen für das neue Projekt zum Controllino. Klicken Sie dann auf die Schaltfläche .
Beachten Sie, dass das Laden der Anwendung möglicherweise einige Zeit benötigt – auch falls die Fortschrittsanzeige dafür bereits geschlossen ist. Beispiel: Für Projekte mit wenig Code benötigt das Laden der Anwendung ca. 30 Sekunden. Die Anwendung wurde erfolgreich geladen, falls Läuft als Ausführungstatus angezeigt wird.
Weitere nützliche Informationen: Anwendung kann nicht erstellt oder geladen werden
logi.cals empfiehlt Ihnen, die aktuellesten Versionen von logi.CAD 3 und des Laufzeitsystems zu installieren und zu verwenden, damit Sie stets über die neuesten Features und Problembehebungen laut den Release-Notes verfügen.
Hat Ihnen dieser Artikel weitergeholfen? Fanden Sie die benötigte Information in der Benutzerdokumentation?
Falls nicht, kontaktieren Sie das Support-Team von logi.cals. Geben Sie Ihre Fragen oder Ihre Vorschläge zur Verbesserung/Erweiterung der Benutzerdokumentation so detailliert wie möglich an.